Import Model from the Excel Spreadsheet and AutoCAD

Importing Model from the Excel Spreadsheet

This function allows to import the piping geometry from Excel Spreadsheet made using the predefined template.

The template file (Coordinate Import Example.xlsx) is stored in the folder with examples: Help> Example Models

Open the template xls file (Coordinate Import Example.xlsx).

You can add several types of objects: run, bend, valve, tee, flange, reducer. For each object you need to specify two coordinates of start and end nodes. All nodes with exactly the same coordinated will be merged. For tee objects you need to specify 3 nodes. Nominal diameter is automatically converted into the real diameter according to the selected group of standards (ASME, EN, GOST).

Create the mode geometry in the spreadsheet. After that save the file with the new name in (.csv) file format (File > Save as)

After that create the new project file in START-PROF. Import the csv file using: File > Import > From Excel SpreadSheet (.csv)

Importing Model from AutoCAD

This function allows to import the piping geometry from Excel Spreadsheet created using AutoCAD.

Before running the data extraction, need to convert the Pline and 3Dpoly entities into Line entities. ARC entities are not supported yet.

Draw the piping axis using the line elements in Autocad. After that select Annotate tab > Tables panel > Extract Data. Extract only line geometry, the start and end point coordinates into Excel file.

Open the (.xlsx) file in Excel and save it with the new name in (.csv) file format (File > Save as)

After that create the new project file in START-PROF. Import the csv file using: File > Import > From AutoCAD (.csv)

Troubleshooting

Please note, that "decimal symbol" and "List separator" options in the system should be the same when exporting csv file from START-PROF and opening it in MS Excel.

To check these options please go to Start Menu > Settings > Time and Language > Date, Time, & regional formatting > Additional date, time, & regional settings > Change date, time, or number formats > Additional settings

Menu Access

File > Import > From Excel Spreadsheet (.csv)

File > Import > From AutoCAD (.csv)